调用JS时提示“blockui requires jquery v1.2.3 or later you are using v1.11”如何处理

今天上班在弄一个新的客户站点时,调用JS无意中发现这个问题,一头雾水,以为要去下载新的文件替换。

后来查看了一些大神的分享,原来很简单,修改下jquery.blockUI.js里面对应的编码内容即可。

在文件里搜索这个旧内容

//if (/1\.(0|1|2)\.(0|1|2)/.test($.fn.jquery) || /^1.1/.test($.fn.jquery)) 

修改为:

//new if condition if ((/1\.(2\.([3-9]|[1-9][0-9])|[3-9]\.[0-9]*|[1-9][0-9]*\.[0-9]*)/.test($.fn.jquery)) === false )

未经允许不得转载:采玩狗 » 调用JS时提示“blockui requires jquery v1.2.3 or later you are using v1.11”如何处理

评论 0

评论前必须登录!

登陆 注册